演示

请输入图片描述

网站由朱纯树开发


要求

PHP >= 7.3

Swoole PHP 扩展 >= 4.5,并关闭了 Short Name

https://hyperf.wiki/2.1/#/zh-cn/quick-start/questions?id=swoole-%e7%9f%ad%e5%90%8d%e6%9c%aa%e5%85%b3%e9%97%ad

OpenSSL PHP 扩展

JSON PHP 扩展

PDO PHP 扩展 (如需要使用到 MySQL 客户端)

Redis PHP 扩展 (如需要使用到 Redis 客户端)

开始

在合适的位置创建一个目录,cd进去并执行:

git clone https://github.com/zhuchunshu/vpsdie.git .

如果是国内机器则执行

git clone https://gitee.com/zhuchunshu/vpsdie.git

克隆完项目之后执行:

composer install

运行完毕执行:

cp .env.example .env

然后编辑.env文件,配置好数据库信息以及APP_NAME

接下来迁移数据库:

php ./bin/hyperf.php migrate --force

然后创建管理员账号

php ./bin/hyperf.php CodeFec:Init

最后运行

php ./bin/hyperf.php server:watch

如果不报错就是运行成功了,中断后把此命令守护起来就可以啦

最后反向代理下 127.0.0.1:9501就好了

然后访问你的域名/admin即可进入管理后台


演示站点:https://www.vpsdie.com/

源码地址:

此处内容需要评论回复后(审核通过)方可阅读。

最后修改:2021 年 07 月 03 日 08 : 50 PM
如果觉得我的文章对你有用,请随意赞赏